Go Back   Pet forum for dogs cats and humans - Pets.ca > Discussion Groups - mainly cats and dogs > Dog health - Ask members * If your pet is vomiting-bleeding-diarrhea etc. Vet time! > Puppy health

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old May 17th, 2008, 07:34 AM
London's Avatar
London London is offline
Junior Member
 
Join Date: May 2008
Location: Alexandria, VA
Posts: 10
Unhappy 5 month doberman with has 2 UTI's - Answered by Dr. Lee

Approximately 1 month ago my husband and I noticed that London, our 4.5 month old (at the time) female doberman pinscher was urinating very frequently, including in the house, and it had a terrible odor along with small clots of blood.

We immediately took her to our veterinarian and when they took a urinalysis they told us she had a UTI and gave us 2 weeks of antibiotics. Over the 2 weeks, we saw no blood, and she was urinating normally (outside!!). 4 days after we stopped the antibiotics, we noticed the foul smelling urine, again with blood clots, and frequent urination.

This time we took her to another vet simply because of recommendations from other pet owners. This time, we had a urinalysis done (which obviously showed she had a UTI), blood work, and an x-ray to check for stones or anything not may not be properly developed. The x-ray turned out fine so now we are waiting until next week when we get results from a lab indicating exactly what kind of bacteria(s) is causing this. At that time, we will put her on the proper medication.

Does anybody have any other ideas of what you think it might be?

We usually take her to the dog park a few times a week, which let's face it, is never a really clean place.

We feed her Solid Gold puppy, and because she likes it, I very seldom add water to it. I recently read to no longer do that, as bacteria builds up as it sits there.

She also stays in a crate while we are at work during the day. Before we noticed the blood in her urine again, we noticed she was urinating in her crate a little more often than normal and lying in it for the few hours we are gone. We are always sure to clean the crate very well before puting her back in, but could it possibly build up harmful bacteria in the time we are gone?

ANY input would be helpful as we want to get our baby taken care of!!
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Forum Terms of Use

  • All Bulletin Board Posts are for personal/non-commercial use only.
  • Self-promotion and/or promotion in general is prohibited.
  • Debate is healthy but profane and deliberately rude posts will be deleted.
  • Posters not following the rules will be banned at the Admins' discretion.
  • Read the Full Forum Rules

Forum Details

  • Powered by vBulletin® Version 3.8.7
    Copyright ©2000 - 2014, vBulletin Solutions, Inc.
    vBulletin Optimisation by vB Optimise (Reduced on this page: MySQL 9.09%).
  • All times are GMT -5. The time now is 08:10 PM.